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Text Editor 
A very basic word 
processor that offers 
no formatting 
whatsoever, just 
text. 
 
Proprietary Code 
Pieces of HTML that 
are unique to 
particular software 
and have little or no 
importance to the 
actual page. 
 
Redundant Tags 
HTML tags that are 
completely 
unnecessary. 
 
Local Site 
The folder where all 
your web pages and 
images are saved on 
your desktop 
computer. 
 
Remote Site 
The computer that 
stores the actual 
website – the Web 
Server. 
 
Web Server 
The computer that 
stores and ‘serves’ 
your website to the 
world. Usually your 
workplace IT 
department or ISP 
(Internet Service 
Provider). 
 
Root 
The folder in which 
all your web files are 
saved. 
 

 
Creating web pages using Dreamweaver 
 
 

1. The Design view in Dreamweaver 
2. Setting up your Local Site and Site Structure 
3. Page set up 
4. Inserting content (Text & Images) 
5. Creating and checking links 

 
 
 1. The Design view in Dreamweaver 

 
 
Dreamweaver offers three types of view with 

which to develop your pages. If you prefer to work 
directly with HTML code, you can use the full HTML view, 
which is an excellent text editor. For those who like to 
see the HTML being generated while working in the 
design view, then Dreamweaver offers a split screen, 
giving you the design view in a lower pane of the window 
and an HTML view in the upper pane (Fig. 1).  
 

 
Fig. 1 

This view is great if you want to enhance your HTML skills and also makes 
navigating your way around the HTML much easier. Just highlight the 
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component on the page in the design view and the corresponding HTML will 
also be highlighted.  
 
For extra guidance with your HTML, Dreamweaver offers you the O’Reilly 
Code reference. Just click on Window > Reference on the page task bar to 
check it out. Finally and fairly obviously, you 
can work in the full design view. This is really 
what it’s all about and what makes 
Dreamweaver so easy to use. One of the 
unique features about Dreamweaver is that it 
doesn’t write any proprietary code into your 
pages and doesn’t alter your code. This isn’t to 
say that Dreamweaver is perfect. It isn’t and 
you will come to learn about its strengths and 
weaknesses. It does however offer you the 
facility to clean up your code, removing 
redundant tags and getting rid of all those nastie
have dropped into it, especially if you have import
Microsoft Word, for example. 
 
 

 

2. Setting up your Local Site and Site Structu

The Local Site referred to means the site o
and its relationship to the remote site on the web
local site, you are telling Dreamweaver where you
for a particular site. You will need to define a loca
that you work on. 
 

 

Fig. 4 Site Definition dialog
 

 
 

Tip 
 
A Very Important Note here:  
 
When working with web files 
ALWAYS use lower case 
names, with NO SPACES. If 
you need to distinguish 
between words, use an under 
score: my_web.html for 
example 
s that other software might 
ed some content from 

 
 

re 

n your desktop PC or Mac 
 server. When you define your 
 are going to save all the files 
l site for each of the websites 
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Exercise 1 
 
It is essential that you create a root folder before opening Dreamweaver, so 
browse to drive D on your PAWS PC and locate the folder USR. In this folder 
create a folder called root. 
 
1. Open Dreamweaver 

2. A blank document will open. 

3. Choose Site > New Site 

4. In the Site Definition dialogue box (Fig. 4), make sure that Local Info is 

highlighted under the Category menu. 

5. In the Site Name field, enter a name for your site, e.g. my_site (note the 

underscore instead of a space. Also, never use upper case letters)) 

6. In the Local Root Folder box, click the little folder icon and navigate 

your way to your root folder that you have previously created and click 

select. 
7. In the HTTP Address box type www.kcl.ac.uk after the http://. 
8. Under Cache, select Enable Cache 

9. Click OK and OK to the cache message 

10. Click on Site Window  at the 

bottom of the blank page and the Site Window will open. 

 

You are now ready to create your site structure. 
 Keywords 

 
Cache 
 
This is an area on your 
hard disk that stores all 
the links on your site. 
Dreamweaver uses this 
cache to perform link 
updates whenever you 
change the location or 
name of a file or folder 
WITHIN Dreamweaver, 
If you change any of 
these things outside 
Dreamweaver, then the 
cache is not used and 
the links will not be 
updated. 

Exercise 2 
 

• In the Site window (Fig. 5), in the right hand 

pane you will see your root web folder. This 

is where ALL your web documents will be 

saved. Saving folders, files and other 

documents outside this root folder will mean 

that any links made to these will not work 

when you publish your web files. 

 

• Right click on your root folder and click on 

New File. A new file icon will appear 
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underneath the root folder. By default it is named untitled.html. 

Rename this file index.html by right clicking on it and choosing 

rename. It is VERY IMPORTANT that you name all your files with an 

.html extension. Do not use .htm extensions; they may not work in 

the King’s web site. (In any event, it is always safest to use the .html 

extension and NEVER mix the two) 

 

 

Site Window 

Fig. 5 The Site Window 

 

• Next, right click on the root folder again and this time, choose new 
folder. Name this folder images. This is where you will save all the 

images – graphics, photographs etc that are common to the site as a 

whole. If you have multiple directories or sections in your site it is a 

good idea to have separate image directories for each section. When 

your site becomes more complex it will be much easier to administer 

if you have an intuitive site structure. For the King’s website you will 

not need to create many graphics as these are all supplied and 

automatically included with the server-side-includes (more on this 

later). You may however wish to include some photographic images.  
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Images Folder 

Index.html 

Fig. 6 Organising the Site Structure 

 
 

 3. Page set up 
 

 
Using tables for page layout 
 

In the old days when web pages were hand coded and all 
images and text were left aligned by default, tables were used to 
present tabular data. It wasn’t long though, before the pioneering 
web designers realised that tables could be used to give more 
control over page layout, thus dramatically increasing their design 
options. Tables enable you to create quite complex layouts for whole 
pages. 
 
Those of you who are used to using tables in Word for example, will 
know just how easy it is to manage the information within each cell 
of the table without it affecting the contents of adjacent cells. One of 
the most tiresome parts of hand coding web pages is creating tables 
and this is where WYSIWYG web creation tools are most 
convenient.  
 
Before you start, it’s a very good idea to resort to good old pencil 
and paper to plan out your table and its contents. It will save a lot of 
angst later on.  When you are reasonably happy with your ideas you 
can get to work placing the table into your web page. Dreamweaver 
provides two ways of creating tables (apart from hand coding, that 

 
 

Glossary and 
Tips 
 
Tables 
Tables are made 
up of rows, which 
cross horizontally 
and columns, 
which span the 
table vertically. 
 
Cursor 
Or Mouse Pointer. 
 
 
Objects Pallet 
Click on Windows 
> Objects to see 
the pallet. This is a 
frequently used 
pallet and is worth 
keeping open. It 
can be ‘docked’ 
anywhere on your 
desktop or left 
‘floating’. 
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is.), inserting the table in the usual way (Insert > Table) or use a new feature in 
Dreamweaver – Layout Tables (see the side bar on page7). 
 
 
Exercise 3 
 
Creating a table. 
 

• Open index.html 
• In design view, place the cursor at the location that you want to insert the 

table 
• click on the Insert Table icon  on your Objects Pallet. The Insert 

Table dialogue box will appear (fig. 7). 
 

• Complete the various boxes as seen in the fig. 7, then click OK.  
 

 
 

Fig. 7 Insert Table dialogue box 
 
 
A table will appear on your page. 
 
 

 
 

Fig. 8 a table shown within the design view 
 
Note that the table is left aligned. This will mean that the web page will also be 
left aligned. You may want your pages to be centred. If so, click outside the 

table to deselect it and click on the centre text button  on the 
taskbar.   
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About Spacer 
GIFs. 
 
An ‘image’ spacer 
is a 1 pixel by 1 
pixel transparent 
gif that is re-sized 
in order to force 
the width of a 
column or height 
of a row. 
Layout Tables 
 
There is another way of creating and managing tables in 
Dreamweaver. Basically you draw some boxes on the page and 
then Dreamweaver fills in the HTML for an entire page design. 
These layouts are drawn using tables – known as layout tables. 
The only difference is that Dreamweaver will automatically 
generate spacer gifs, which are invisible, one-pixel images. 
These are used to force the spacing of tables. These spacer gifs 
have been used for some time now as a ‘workaround’ for some 
Netscape incompatibilities. They work really well in any browser 
and can give you much more control of your tables. The team at 
Macromedia have simply made the process easier by 
incorporating it into Dreamweaver. 
 
 
All that remains to do now is populate the table with content. 
 
 

 
 

 
Content. Now there’s a word for all you budding web 

designers to conjure with. Content can be anything form text, 
through forms and graphics to photographs to flash 
animations. It also includes streaming media, MP3 files and 
almost anything else you can think of. But remember, less is more – especially 
with the King’s house style. 

Irrespective of any 
content present, 
the column or row 
will maintain the 
dimensions forced 
by the gif. The 
advantage of this 
is that you can use 
the same gif for all 
your pages – the 
dimensions are 
controlled within 
the HTML of the 
individual page. 

4. Inserting Content (Text & Images)

 
Text 
 

Text is made up of a series of words made up of font styles 
and font sizes. OK, so you knew that. But text comes in all 
shapes and sizes – especially on the web. It’s quite a strange 
phenomenon that, given a folder full of different font styles, 
most people lose their usual reserve and reason. It seems like 
anything goes. Well, take my word for it – it doesn’t. Apart from 
the fact that there are very few font styles that will render 
correctly in a browser, it’s worth remembering that unless a 
font style is actually installed on the visitors’ computer, it will 
not display on your web page. Instead, your browser will find a 
font that it thinks is similar. Inevitably your page will end up 
looking nothing like you intended. So, choose a font that is 
guaranteed to be resident on almost every computer 
(Dreamweaver thoughtfully groups them together for your 
convenience, in the Properties panel),  

Tip 
 
Page Preview 
If you hit the 
F12 key on 
your keypad 
you will be 
able to 
preview the 
page you are 
working on. 
Notice that 
despite what 
you see in the 
design view, 
the table is 
invisible. 

 
What makes some people think that green text on a grey background is cool is 
a mystery to others and completely invisible to some colour blind people. In 
saying this I am assuming that the majority of people who publish information 
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on the web actually want someone out there to read and understand what they 
have painstakingly created. 
 
 

 
 

Fig. 9 The Fonts List 
 

Use the Font drop down menu to view the fonts list and choose Arial, Helvetica, sans serif. 
 
 

 
So, lets keep it nice and simple and in keeping with 
the rest of the site. In any event, never use more than 
three font styles in a site and try not to use too many 
different font sizes. Do not use italics. The smaller 
sizes are almost impossible to read on LCD monitors. 
If you need to enhance a word or sentence try 
emboldening it instead. Never use emboldening and 
capital letters at the same time. This is over egging the 
pudding as my Grandmother used to say. Go easy on 
coloured text. You wouldn’t use it for your CV, so why 
use it in a web page. 
 
 

 
 

Tip 
 
Comic Sans – 
everyone’s favourite font 
style. It’s fun and it’s 
funky. Well, actually it’s 
unprofessional looking, 
but if you want people to 
think the person who 
created your site is aged 
8, go ahead. 
 

 

So, enough of the don’ts, lets look at some of the do’s. 
 
Manipulating text in Dreamweaver is very similar to using any decent word 
processing software. Apart from font styles and sizes, which I’ve mentioned 
above, you can spell check, find and replace, insert special characters, use 
numbered lists and bulleted lists. 
 
 
Placing images and text in your web page. 
 
There are a number of ways to put text into your web page 
using Dreamweaver. You can copy some text from another 
program and past it directly into the Dreamweaver window, 
you can convert a word processing or text document into 
HTML and then open it in Dreamweaver or, most simply, you can just type text 
directly into the Dreamweaver window. 

Tip 
 
The whole text affair 
can be controlled 
with Cascading 
Style Sheets, but 
more on this later. 

 
 
 

 
 

8



 

Exercise 4 
 
Using the table that you created earlier in index.html, use the split view to watch 
the HTML code being generated: 
 
 

• Drag across the first and second left column in the middle row so that the 
two cells are highlighted. (Fig. 10) 

 
 

 
 

Fig. 10 
 
In the bottom left of the Property Inspector you will notice the word cell. Below 
this you will see a small icon for merge cells. (Fig .11) 

 

 
 

Fig. 11 Properties panel 
 

• Click this button to merge the cells. 
• Place your cursor in the top right hand cell. 
• In the Properties Palette click into the W box and enter 100 (This will 

prevent this column from collapsing whilst you work with the table. 
• Drag over the first and second left column in the bottom row and merge 

them also. 
 

On your floppy disk you will find a text document – chancery_lane.txt and a 
photographic image – chancery.jpg 
 

• Place your cursor in this new middle left hand cell and choose Insert > 
Image, or click the insert image icon  from the Objects Palette. 

• Navigate to your floppy disk and choose chancery.jpg 
• You will now be asked if you want to copy this image to the root folder of 

your site.  Choose yes. 
• Navigate to your root folder and then to the images folder. 
• Click Save. 
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You will now see the image displayed in the table cell. 



 

 
You will also see in the Properties Inspector a thumbnail and the properties of 
your image - the size in bytes, the dimensions in pixels and the source of the 
image (i.e., where it is saved in the local root). 
 
With the image selected, notice the Alt box on the right of the Properties 
Inspector (Fig.12). This is known in HTML as the Alt Tag.  
 

 
 

Fig. 12 
 
Type in a familiar title for the image – in this case, Chancery Lane 
 
Now, save this page and then preview it in the browser. 
In the browser window, hover your mouse pointer over 
the image…what do you see?  
 
Adding Text 
 

• Place your cursor in the top left hand cell. 
 

• Navigate to your floppy disk and open text.txt 
 

• Highlight the title – Chancery Lane Library Opens
 

• Go back to your Dreamweaver page and paste the
hand cell. 

 
• In your text document, highlight the body text and

 
• In Dreamweaver, place your cursor in the right han

text. 
 

• Don’t panic. 
 

• Place your cursor into the top right hand cell and cle
Properties palette. 

 
• Hit the return key – the text will now spread out, but

 
• Place your cursor in the cell that contains the image

easier if you highlight the image itself and then hit th
 

 
 

Tip 
 
Alt Tags are not only
useful for identifying 
images in a browser 
but are essential for 
‘text to speech’ 
software that ‘reads’ 
web pages to those 
with impaired sight. 
 to Students 

 text into the top left 

 copy it. 

d cell and paste the 

ar the value in the 

 will still look wrong. 

 – you might find this 
e ‘end’ key. 
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• In the properties palette, click on the Vert drop-down menu at the 
bottom left and choose Middle. Your image will now move to the middle 
of the cell. 

 
You will see that the body of the text takes up more space than the image. 
 

• Now we need to cut and paste the text into the individual cells, merging 
them where necessary, until the text is balanced with the image. 

 
You will notice that everything seems close together, with no margins or 
spacing. 
 

• Select the table by hovering your mouse over the outside border of the 
table until the mouse pointer changes to a double arrow and click. 

• The table boundary will have become emboldened. This shows that it is 
now selected. 

• In the properties palette click on the Cell Pad box 
 

 
Fig 13. 

 
Information 
 
The most important 
element of Hypertext 
Transfer Protocol – the 
http bit at the beginning 
of web URLs – is the 
word hypertext. 
 
Careful with that link!! 
 
Why not use the whole 
URL every time? Well, 
it’s simple really. 
Dreamweaver can keep 
track of all your relative 
links and make sure that 
they are always OK. (It 
also saves time typing in 
all that http://www 
malarkey and it cuts 
down on the chances of 
you making a mistake.) 

• Type in 5 to give the cell a padding of five 
pixels 

 
Again, everything will move to reflect the new table 
setting. Now, you need to format your text. 
 

• Highlight the title. 
• In the Properties palette use the font drop 

down menu and choose the font group Arial. 
• Also, choose size 4. 
• Highlight the rest of the text, cell by cell and 

choose the same font group for each. 
• Choose font size 2 for each. 
• Click outside the table to see the effects of 

your changes. 
• Preview the page in your browser. 

 
Looks better already. 
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A hyperlink or simply a link is a pointer from one web page to another. The page 

that contains the link is called the referring page and the destination of the link 

is called the target.  

 

Types of Links 
You need to be aware of the different types of path names that you can use to 

link one document to another on the Internet. There are four different kinds that 

you can use. 

 

• Absolute pathnames (http://www.kcl.ac.uk/index.html) points to a 

location on the Internet that is outside the site currently being viewed. 

• Document-relative pathnames (index.html, ../contacts.html) point from 

the current page to another document within the same site, using dots 

and slashes to tell the browser when to look in other directories to find 

the page. You can link from one document to another without using the 

full URL (http://www.blahblahblah.com) Dreamweaver will keep track of 

what it all means 

and make sure that 

your links are 

correct when you 

update your site, so 

long as you make 

these changes in 

Dreamweaver. 

• Site-root-relative path
current document to an

and slashes to indicate

at the home directory a

that might be modified

links will still be correc

• Named anchors (#top

or to specific location o

 

 
 

Remember. 
 
You can create several types of links in a web page: 

• A link to another page, document or file 

• A ‘named’ link to another part of the same page 

• An email link 

• A link to another web site 
5. Creating and checking link
names (/contacts.html) also point from the 

other within the same site. Instead of using dots 

 the location of the document, the browser starts 

nd looks for the page from there. In a large site 

 outside Dreamweaver, these site-root relative 

t, even if the page is moved. 

) link to a point within a page either the same page 

n another page (../contacts.html#theboss). 
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Making links 
 

Making links in Dreamweaver is so easy you could almost do it with your eyes 

closed. The Property Inspector will enable you to put your links just where you 

want them, and I mean RIGHT where you want them, so be careful what you 

highlight when you’re putting your links in. 

 

Using Dreamweaver, there are several ways to create links: 

 

• Use the site map window to view, change or create links. 

• Use Modify > Make Link to select a file to link to. 

• Use the Selection Properties box to link to a file, by using the folder 

icon to browse to and select a file, using the point to file icon to select a 

file or by typing in the file path. 
 
To make a text link 

 

Remember to be intuitive when creating 

text links. Click here to go to blah, blah 

might sound OK but what do you click, the 

word here or the whole sentence? It’s 

generally not a good idea to hyperlink 

more than a couple of words. Apart from 

anything else if the hypertext is set to be 

underlined and is a different colour to the rest of the text, it will look horrible. 

Link colours 
 
Link colours are part of Page 
Properties. You can specify the colours 
of links in order to match the rest of the 
document or to contrast with the rest of 
the document. The colour you choose 
should make the text remain obvious. 
After all, you don’t want visited links to 
suddenly disappear after you’ve clicked 
on them. It is worth remembering 
though, that these colours can be 
overridden by users’ individual settings 
on their local machines. This may 
discourage you from bothering to 
specify link colours in the first place. 

 

Example: 

 
 

A

 

 

 

 
 

Click here to go to our interactive web site where you can see up-to-
minute details of vacancies, the skills required and then apply on-line.
 better solution would be to be a bit more literal. So.. 
Click here to go to our interactive web site where you can see up-to-minute 

details of vacancies, the skills required and then apply on-line. 
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..looks much better, don’t you think? 

 

Highlight the text that you would like to make a link from. Obvious examples are 

home, contacts, etc.. Links to other websites can also be accessed via text. 

In the Properties Inspector click inside the link box and type in the URL. If this 

is an external website remember to include the http:// part of the address 

otherwise the link wont work. If you are linking to another page within the same 

website click on the little folder icon next to the link box and navigate to the file 

that you want to link to. Dreamweaver will automatically create the correct 

relative link, which you will be able to see in the link box when you click select. 
 

Exercise 5 
 

• Highlight The beginning of the first paragraph – King’s College London 
and create a link to the King’s website 

 

 
Linking to a ‘named’ anchor 
 

This is very useful for navigating a long page of information or a particular point 

in another page. Placing a named anchor at a strategic point in a document 

allows the visitor to take a ‘short-cut’ and quickly move to that point. 

 
Exercise 6 
 
To create a ‘named’ anchor 

 

• In the document window, place the cursor where you want the anchor. In 

this case to the left of the title. 

• Click on Insert > Invisible Tags > Named Anchor. 

• In the Anchor Field type in the name for your anchor. Make it a name 

that reminds you of the anchor point. In this case call it top. You may 

have several anchors and it is essential to be able to distinguish between 
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them. The anchor marker should appear at the insertion point. If it 

doesn’t, choose View > Invisible Elements. 
 

To link to a ‘Named Anchor’ 
 

• In the Document Window select the text or image to create a link from. 

• In the Link field of the Selection Properties box, type a cross-hatch (#) 

followed by the name of the anchor. For example: 

• To link to an anchor named ‘top’ in the current document, type #top. 

• To link to an anchor named top in a different page in the same folder 

(i.e., the same section of the site) type filename.html#top. 
 

To link to a named anchor using the ‘point to file’ method 
 

• Choose View > Visual Aids > Invisible Elements to make the anchor 

visible. 

• Select the text or image in the document window. 

• Click the ‘point to file’ icon to the right of the Link field in the Selection 

Properties box and drag to the anchor that you want to link to; either an 

anchor within the same document window or in another open document 

window. 

 

Exercise 7 
 
Creating an email link 

 

Clicking an email link opens a new message window (using the default email 

programme on the users computer). In the email message window the To field 

is automatically completed with the address specified in the email link. 

 

To create an email link using the Insert Email Link command 

• We will use Arthur Lucas in the last paragraph to create an email link 
 
• In the Document Window, position the cursor where you want the email 

link to appear, or select the text that you want to act as the email link. 
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• Choose Insert > Email Link or click on the email button on the Objects 

palette. 

• In the text field of the Insert Email Link dialogue box type or edit the 

text, as you want it to appear in the document. 

• In the Email field, type in the email address that you want mail to be 

sent to. 

• Click OK. 

 

To create an email link using the Properties Inspector 
 

• Select the text that you want to act as the email link. 

• In the Link field of the Properties Inspector, type in mailto: followed 

by the appropriate email address. 

 

Checking your links 
 

Checking links is also very easy in using Dreamweaver. This is why the cache 

(that should have been created when you defined your site) comes into its own. 

 

Exercise 8 
 

Choose File > Check Links and Dreamweaver will check all the links on that 

page. If there are any that are broken it will not only let you know, but will also 

highlight the broken link in the HTML view.  

 

Bear in mind that only the links on your hard drive will be checked, so you might 

get a report back that says you have some broken links. These will be external 

links and should be checked when you publish your pages on the server. 

Remember; always check your links when they have been uploaded. 

 

   There’s many a slip twixt cup and lip.. 
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